AttributeError: 'VariantDataset' object has no attribute 'summarize'

I got the error in the title and solved it, if anyone has the same problem - my spark versions didn’t match.
I changed the following line:
$ ./gradlew -Dspark.version=2.0.2 shadowJar
$ ./gradlew -Dspark.version=2.1.0 shadowJar
in order to match the spark version I had, and it worked.
I think it’s worth mentioning this in the docs to save time for other people :slight_smile:

Thank you for posting something you’d already solved - this is how we can build out good community resources together!

Did you also pull the latest version of the code before recompiling? The summarize method was added in the initial version 0.1 commit, and would expect to get this error if you were running a pre-0.1 version. If not, it’s possible that the version mismatch triggered some odd behavior here, and I’m curious how!

We can add something to docs / FAQ as soon as we pin down the root cause.

I suspected this was the case, so I re-cloned the repo and still experienced the problem. Eventually I realised I didn’t have the right spark version so I tried to change the command above instead of re-installing spark and it worked :slight_smile:

Thanks for the update! I’m still mystified, but am mostly content to blame this on Gradle.