Cannot use exome_v7.1

I received an email that the srWGS smaller callsets are upgraded to v7.1. Here is the path of exome I tried: gs://fc-aou-datasets-controlled/v7/wgs/short_read/snpindel/exome_v7.1/multiMT/

and I received this error.

Java stack trace:
is.hail.utils.HailException: incompatible file format when reading: gs://fc-aou-datasets-controlled/v7/wgs/short_read/snpindel/exome_v7.1/multiMT/
supported version: 1.6.0, found 1.7.0
The cause of this error is usually an attempt to use an older version of Hail to read files generated by a newer version. This is not supported (Hail native files are back-compatible, but not forward-compatible).
To read this file, use a newer version of Hail.

I’m using workbench version 7 so I don’t know why I received an error about supported version discrepancy. Has anyone try the new dataset and succeeded?

1 Like

Any solution for this error? I am facing the same error.

@aou_user_01 , @asppagh54 ,

This means you’re using an older version of Hail than the version which was used to generate that matrix table. You can update your version of Hail with pip (pip install -U hail), but I’ll also contact AoU to ask if they can update the default version of Hail in the AoU RWB.