Cannot import gnomad.utils.annotations.sor_from_sb()


I have the import error as below.

I am trying to annotate ‘FS’ and ‘SOR’ parameters using ‘get_site_info_expr(mt, … , array_sum_agg_fields=[‘SB’])’. However, we can see only ‘FS’ value in the results, without ‘SOR’.

Considering both issues, it seems that sor_from_sb() is not working well now.

Please review this issue. Thank you.


Which version of gnomad_methods do you have installed?

python3 -m pip show gnomad

Thanks, Dan. I can get the information from the command you suggested.

Name: gnomad
Version: 0.3.0

I just updated gnomad to v0.4.0 and re-run my code, but unfortunately, I got the same error.

Does this work?

python3 -c 'import gnomad.utils.annotations.sor_from_sb'

Unfortunately, I got an error again.

Traceback (most recent call last): File "<string>", line 1, in <module> ModuleNotFoundError: No module named 'gnomad.utils.annotations.sor_from_sb'; 'gnomad.utils.annotations' is not a package

By the way, python3 -c 'import gnomad.utils.annotations.fs_from_sb'' also has the same error.

But, It works as below in python3 mode.
>>> from gnomad.utils.annotations import (fs_from_sb, get_adj_expr, get_lowqual_expr, bi_allelic_expr)

It does not work as below.
>>> from gnomad.utils.annotations import (fs_from_sb, get_adj_expr, get_lowqual_expr, bi_allelic_expr, sor_from_sb)

Sorry, I think this issue is caused by gnomAD’s documentation. The docs at describe the latest development version of the gnomad package, not what’s currently available on PyPI.

In this case, the sor_from_sb function was added since the last PyPI release. To use it, you could install the package from GitHub (

Hello Nick,

Thank you for explaining this issue. I will try this function by referring to your GitHub.