No module named 'SocketServer'

I installed Hail 0.2 using pip: pip install hail, and tried to import it in ipython but it gave me an error:

ModuleNotFoundError: No module named 'SocketServer'

Here is full stack trace:

<ipython-input-1-e24d842d2b9a> in <module>
----> 1 import hail

/hail/python/hail/ in <module>
----> 1 import hail.expr
      2 from hail.representation import *
      3 from hail.context import HailContext
      4 from hail.dataset import VariantDataset
      5 from hail.expr import *

/hail/python/hail/ in <module>
      1 import abc
----> 2 from import scala_object, Env, jset
      3 from hail.representation import Variant, AltAllele, Genotype, Locus, Interval, Struct, Call

/hail/python/hail/ in <module>
----> 1 import SocketServer
      2 import socket
      3 import sys
      4 from threading import Thread

I have Python 3.7.3, java:

openjdk version "1.8.0_212"
OpenJDK Runtime Environment (build 1.8.0_212-b04)
OpenJDK 64-Bit Server VM (build 25.212-b04, mixed mode)

And OS:

|LSB Version:|:core-4.1-amd64:core-4.1-noarch|
|Distributor ID:|RedHatEnterpriseServer|
|Description:|Red Hat Enterprise Linux Server release 7.2 (Maipo)|

If I run pip show hail I get Version: 0.2.61 of it.

This means you’re using a Python 2 version of IPython. Check ipython --version.

You probably have two versions of python installed and the Python 2 version has ipython installed but the Python 3 version does not.

Thank you! Solved: just was having set long time ago $HAIL_HOME in .bashrc set to Hail 0.1.