Unable to connect to Jupyter notebook

Hi,
I’m running the following commands:

hailctl dataproc start project-name --region us-east4 --zone us-east4-c --packages gnomad 
hailctl dataproc connect project-name notebook --zone=us-east4-c

These run just fine, but I am unable to connect to the Jupyter notebook with the following error:

# This site can’t be reached

The webpage at **http://localhost:8123/** might be temporarily down or it may have moved permanently to a new web address.

ERR_SOCKS_CONNECTION_FAILED

A few months ago this process worked without any problems on this same machine. Any ideas what could be causing this?

Thank you very much!

Any help with this would be much appreciated!

  • I don’t think it’s a firewall issue: I’m able to ssh into the VM created by “hailctl dataproc start…” without a problem. The VM instance logging on the google cloud console shows no errors.
  • There doesn’t appear to be any another proxy interfering with the SOCKS proxy (following the debugging tips here.

Any tips on what could be going wrong here?

If anybody else encountered this issue, the solution that worked for me was to first create the instance with:
hailctl dataproc start project-name --zone my-region --packages 'ipython<8.22',gnomad